SSL Certificate for Knowledge Base
Incident Report for PhishingTackle.com
Resolved
This appears now to be resolved by our third-party certificate provider, but we are continuing to monitor.
Posted Jul 14, 2019 - 16:05 BST
Investigating
We are currently experiencing an issue with our SSL certificate and will advise when resolved.
Posted Jul 14, 2019 - 15:47 BST
This incident affected: Knowledge Base.