Support Email Issue
Incident Report for PhishingTackle.com
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 19:44 GMT
Monitoring
We have now resolved the support email issue.

If you sent a support email to support@phishingtackle.com between the hours of 10:00 and 14:00 today this may not have been delivered and we ask that you re-send with our thanks and apologies.
Posted Nov 18, 2020 - 14:27 GMT
Investigating
We are currently experiencing a problem with the delivery of support emails. If you require support please use the instant chat until this is resolved, at which point we will update this message.

We apologise for any inconcenience.
Posted Nov 18, 2020 - 13:38 GMT
This incident affected: Simulated Phishing & Training Platform.