Degraded service on a small number of training videos
Incident Report for PhishingTackle.com
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 17:32 GMT
Investigating
Vimeo is experiencing a slight degradation of service causing some of our training videos to load slowly. The issue is under investigation.
Posted Feb 18, 2021 - 15:58 GMT
This incident affected: Simulated Phishing & Training Platform.