Intermittent performance issues
Incident Report for PhishingTackle.com
Resolved
This incident has been resolved.
Posted May 15, 2023 - 17:45 BST
Update
We believe we have isolated the issue and are working to resolve.
Posted May 15, 2023 - 17:20 BST
Update
We are continuing to investigate this issue.
Posted May 15, 2023 - 16:07 BST
Investigating
We are experiencing intermittent degraded performance and are currently looking into the issue.
Posted May 15, 2023 - 15:19 BST
This incident affected: Simulated Phishing & Training Platform.