Elevated API Errors

Incident Report for PhishingTackle.com

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 18:17 BST

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 16:58 BST

Investigating

We're experiencing sporadic access and performance issues with our main platform and are currently looking into this.
Posted Jul 30, 2026 - 16:57 BST
This incident affected: Simulated Phishing & Training Platform.