Secondary
Incident Report for PhishingTackle.com
Resolved
The issue has now been resolved and we apologise for any inconvenience caused.
Posted Mar 25, 2024 - 19:43 GMT
Investigating
We're experiencing an issue with platform connectivity for some users and are currently looking into the issue.
Posted Mar 25, 2024 - 19:31 GMT
This incident affected: Simulated Phishing & Training Platform.