Scheduled Maintenance Tonight

Incident Report for PhishingTackle.com

Resolved

This incident has been resolved.
Posted Feb 23, 2025 - 18:12 GMT

Investigating

To ensure our platform continues to evolve we will be doing some system updates.

The platform may be inaccessible for short periods during this time. Any scheduled campaigns will continue to run as normal.
Posted Feb 23, 2025 - 17:58 GMT
This incident affected: Simulated Phishing & Training Platform.