Microsoft has declared that the incident is now resolved as of 20:48 UTC on 30 July 2024. We have tested the Phish Hook button within Outlook and have found this is now working as expected.
Posted Jul 31, 2024 - 11:13 BST
Monitoring
Network Infrastructure - Issues accessing a subset of Microsoft services
Impact statement: Starting approximately at 11:45 UTC on 30 July 2024, a subset of customers may have experienced issues connecting to Microsoft services globally.
Current Status: An unexpected usage spike resulted in Azure Front Door (AFD) components performing below acceptable thresholds, leading to intermittent errors, timeout, and latency spikes. We have implemented network configuration changes and have performed failovers to provide alternate network paths for relief. Our monitoring telemetry shows improvement in service availability from approximately 14:10 UTC onwards, but we are investigating reports of specific services and regions that are still experiencing intermittent errors. We will provide an update on our continued mitigation efforts by 18:00 UTC, or sooner if we have progress to share.
This message was last updated at 16:42 UTC on 30 July 2024
Posted Jul 30, 2024 - 18:01 BST
Investigating
Microsoft has reported an issue on their side that may impact our Phish Hook button within Outlook. See this update:
Network Infrastructure - Issues accessing a subset of Microsoft services
Starting approximately at 11:45 UTC on 30 July 2024, a subset of customers may have experienced issues connecting to Microsoft services globally.
Current Status: We have implemented networking configuration changes and have performed failovers to alternate networking paths to provide relief. Monitoring telemetry shows improvement in service availability from approximately 14:10 UTC onwards, and we are continuing to monitor to ensure full recovery.