Incomplete Reporting Data

Incident Report for PhishingTackle.com

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 12:24 GMT

Update

We are continuing to investigate this issue.
Posted Feb 26, 2026 - 09:19 GMT

Investigating

We're experiencing a delay in reporting data synchronisation so some reports may contain incomplete data - this should be resolved shortly.
Posted Feb 26, 2026 - 09:19 GMT
This incident affected: Reporting.